GTAGames.nl

GTA2 Editor

Van WikiGTA - De Nederlandse Grand Theft Auto Walkthrough!
Ga naar: navigatie, zoeken
De GTA2 Map Editor

Met de GTA2 Editor (vaak de GTA2 Map Editor genoemd) kun je levels ontwerpen voor GTA2. GTA2 levels worden opgeslagen als een GBH Map File (*.gmp) en staan in de map GTA2/data.

Met de editor kun je gebouwen maken, wegen aanleggen, lichten aanbrengen en nog veel meer. Op deze pagina vind je een uitgebreide uitleg over de functies van deze editor. Meer specifieke tutorials vind je in de modding tutorial onder "Mapping" en zijn ook in de tabel onderaan deze pagina aan te klikken.

Functies

Gereedschappen en functies

Bovenaan zie je een aantal knoppen met gereedschappen en functies. Wanneer je de cursor op één van de knoppen houdt, zie je welke functie deze heeft.

New Open een nieuwe, lege map
Open Open een eerder gemaakte map
Save Sla de map op
Save Compressed Sla de map gecomprimeerd op
Cut Knip de selectie
Copy Kopiëer de selectie
Paste Plak de selectie
Print Afdrukken
About Over de Editor
Help Raadpleeg de waardeloze helpdesk van de Editor
Draw tekengereedschap
Pick Pipet, selecteer de tile waarop je klikt in de Tile Selector
Select Selecteer gereedschap
Rotate draai de tile
Flip X spiegel de tile volgens de X-as
Flip Y Spiegel de tile volgens de Y-as
Flip Area Y Spiegel de selectie volgens de Y-as
Flip Area X Spiegel de selectie volgens de X-as
Rotate Area Draai de selectie
Air Maak de selectie tot lucht en verwijder de geselecteerde tiles
Road Maak de selectie tot weg (inclusief verkeerspijlen) en geef de selectie de ingestelde tile van 'road'
Pavement Maak de selectie tot plein en geef de selectie de ingestelde tile van 'pavement'
Field Maak de selectie tot veld en geef de selectie de ingestelde tile van 'field'
Building Maak de selectie tot een gebouw (block type 'air') en geef de selectie de ingestelde tiles van 'roof' en 'wall'
Overhead Zie de map van bovenaf (TDV)
[geen benaming] Beweeg de camera alle kanten op met de rechtermuisknop (beste optie)
Translate Camera X or Y Beweeg de camera alleen volgens de X en Y-as met de rechtermuisknop
[geen benaming] Beweeg de camera naar boven en beneden met de rechtermuisknop
[geen benaming] Inzoomen en uitzoomen

Tile Selector

Links zie je de Tile Selector. Hiermee kun je alle verschillende tiles selecteren, zoals gras, asfaltweg, verschillende muren, en nog vele anderen. Bovenin de Tile Selector zie je alle beschikbare tiles, en daaronder zie je een vergrote versie van de tile die je geselecteerd hebt. Naast de geselecteerde tile zie je drie knoppen, waarmee je de tile kunt draaien en spiegelen.

Werkveld

In het midden zie je de 3D weergave van de map die je aan het bouwen bent. Dit is je werkveld. In dit veld selecteer je tiles, creëer je gebouwen en zie je hoe je map eruit gaat zien.

Plattegrond

Rechtsboven zie je de plattegrond van je map. Het zwarte vierkantje is wat je ziet van de map in je werkterrein. Blauw is water, grijs is voetgangersterrein, donkergrijs is weg, groen is veld en rood is doorzichtig terrein. Meer uitleg hierover later.

Block info

Onder de plattegrond zie je de Block Info. Hier bewerk je datgene wat je geselecteerd hebt in je werkterrein. De vijf vierkantjes laten zien welke tiles de selectie heeft aan alle kanten. Met 'Block Type' kun je de eigenschappen van de selectie aanpassen naar air, pavement, road en field. Met Arrows geef je de rijrichting aan op de wegen, en met Lid pas je het uiterlijk van de tile aan. In Bottom kun je verschillende dingen veranderen aan het uiterlijk van een tile.

Slope

Bij de Block Info hoort nog een klein los venstertje genaamd Slope. Zie je deze niet bij het opstarten van de Editor, klik dan op de knop 'Slope' in Block Info. Met dit venster kun je de selectie een andere vorm dan vierkant geven. Op deze manier maak je hellingen, schuine muren, schoorstenen, etc.

Coördinaten

Geheel rechtsonder zie je de X-, Y- en Z -coördinaten van de selectie. Deze zijn erg belangrijk wanneer je je script voor je map gaat schrijven.

Sneltoetsen

Naast deze korte beschrijving van de functies zou je de volgende sneltoetsen moeten kennen om goed overweg te kunnen met de editor. Niet alle sneltoesten zijn hier genoemd, alleen de meest belangrijke. In de Editor zelf kun je in de HelpDesk ook een lijst van sneltoesten vinden, deze is echter ook niet compleet. Wanneer de functie van een sneltoets niet geheel duidelijk is, is het het beste om deze gewoon op een aantal manieren te proberen in de editor.

Algemene sneltoetsen

1 Toon texturen
2 Toon Block Types
3 Toon Collission Info
4 Toon Default Tiles (setup in Tools/Setting/Default Tiles)
Rechtermuisknop en muis bewegen Draai/ Beweeg Camera
Ctrl + R ‘Losse Camera’ inschakelen
P Inzoomen
L Uitzoomen
Ctrl + Z Ongedaan maken
Ctrl + Y Terugzetten
Links Scroll naar links
Rechts Scroll naar rechts
Op Scroll naar achteren
Neer Scroll naar voren
Q Maak één toplaag zichtbaar
A Maak één toplaag onzichtbaar
Ctrl + Links Verplaats selectie naar links
Ctrl + Rechts Verplaats selectie naar rechts
Ctrl + Op Verplaats selectie naar achteren
Ctrl + Neer Verplaats selectie naar voren
Ctrl + Q Verplaats selectie naar boven
Ctrl + A Verplaats selectie naar onder
Alt + Links Verplaats selectie naar links (Inclusief blocks)
Alt + Rechts Verplaats selectie naar rechts (Inclusief blocks)
Alt + Op Verplaats selectie naar achteren (Inclusief blocks)
Alt + Neer Verplaats selectie naar voren (Inclusief blocks)
Shift + Q Verplaats selectie naar boven (Inclusief blocks)
Shift + A Verplaats selectie naar onder (Inclusief blocks)
Shift + Links Vergroot selectie naar links
Shift + Rechts Vergroot selectie naar rechts
Shift + Op Vergroot selectie naar achteren
Shift + Neer Vergroot selectie naar voren
Shift + Q Vergroot selectie naar boven
Shift + A Vergroot selectie naar onder
Shift + Ctrl + Links Verklein selectie links
Shift + Ctrl + Rechts Verklein selectie rechts
Shift + Ctrl + Op Verklein selectie achteren
Shift + Ctrl + Neer Verklein selectie voren
Shift + Ctrl + Q Verklein selectie boven
Shift + Ctrl + A Verklein selectie onder
Shift + Del Verwijder de geselecteerde blocks (Eigenlijk is dit hetzelfde als 'knippen')
KeyPad 5 Geef de top van de selectie de geselecteerde tile
KeyPad 8 Geef de achterkant van de selectie de geselecteerde tile
KeyPad 2 Geef de voorkant van de selectie de geselecteerde tile
KeyPad 4 Geef de linkerkant van de selectie de geselecteerde tile
KeyPad 6 Geef de rechterkant van de selectie de geselecteerde tile
KeyPad 0 Geef alle kanten van de selectie de geselecteerde tile

Tekenmodus

(dus tijdens gebruik tekengereedschap)

Linkermuisknop Teken tile onder cursor
Shift + Linkermuisknop Teken alle tiles van de zijde onder selectie
Ctrl + Linkermuisknop Teken alle buitenkanten van de selectie

Selecteermodus

(dus tijdens gebruik selectiegereedschap)

Linkermuisknop Selecteer block als selectie
Linkermuisknop + muis bewegen Selecteer meerdere blocks

Noodzakelijke instellingen

Dit is een heel belangrijk onderdeel wanneer je begint met de GTA2 Editor, maar toch wordt het vaak vergeten. Het is een paar minuten werk, en kan vele uren werk redden. Lees dit dus aandachtig door!

Wanneer je de editor voor het eerst gebruikt, moet je een aantal instellingen invoeren. De editor komt zodra je een nieuwe map opent met de melding "Cannot Open Style File". Dit betekent dat je de afbeeldingen (oftewel tiles) moet invoeren die we gaan gebruiken tijdens het modden. Deze kun je vinden in de map 'data'. Let op: in de map van de editor zelf staat ook een map genaamd 'data', maar deze moet je dus niet hebben!

In deze tutorial wordt gebruik gemaakt van de tiles uit het Downtown District, dus moet het bestand 'wil.sty' geopend worden. Wanneer je niet gelijk een venster krijgt waarin je de .sty files kunt laden, dan kun je dit alsnog doen via Tools > Settings > Startup > Style Files.

Vervolgens is het verstandig om de autosave-functie goed in te stellen. Dit zorgt ervoor dat de editor automatisch opslaat. Aangezien de editor wel eens crasht, kan dit uren werk redden! De Autosave stel je in bij Tools > Settings > Startup. Rechtsboven in het venstertje dat opent zie je 'Autosave' en 'Backups' staan. Ik heb ze beide op 5 staan. Dit betekent dat er om de vijf minuten een backup gemaakt wordt. Wanneer er vijf backups zijn, wordt de oudste verwijderd bij de volgende keer. Tevens zie je links in het venster de optie 'map' staan. Zet deze op "Open last used map file". Dit betekent dat de Editor automatisch je laatst gebruikte map opent.

Problemen bij moderne besturingssystemen

Het is bekend dat de GTA2 Map Editor problemen heeft met nieuwere besturingssystemen zoals Windows XP of Vista . Wanneer je Windows XP of Vista gebruikt heb je grote kans dat de Editor enkele problemen oplevert en in uitzonderlijke gevallen zelfs niet werkt. Het is echter niet noodzakelijkerwijs een onoverkoombaar probleem.

Tile selector probleem

Het bekendste probleem is dat de tiles in de tile selector pas worden weergegeven wanneer je ze aanklikt. Er is helaas geen oplossing voor dit probleem, dus je zult hier aan moeten wennen. Wanneer je enige tijd met GTA2 modding bezig bent, leer je vanzelf waar alle tiles zich ongeveer bevinden en wordt deze bug vanzelf minder problematisch.

Top Down View

De Top Down View van de editor (View > Top Down View) is onbruikbaar in Windows XP, in tegenstelling tot Vista. Deze functie hoort een 2D weergave van je level weer te geven en wordt dus voornamelijk gebruikt om plattegronden mee te maken. De functie is niet nodig om een level te maken.

Zones plaatsen

Het grootste probleem is dat de editor onder Windows XP en Vista crasht wanneer je een zone plaatst. Bestaande zones kun je wel aanpassen, verplaatsen of verwijderen. Dit probleem is op te lossen door je level te maken in de downloadbare map0. Map0 is een leeg level met 175 zones, die je naar believen aan kunt passen.


Grand Theft Auto 2
Features Missies · Voertuigen · Wapens · Power-ups · Car shops · Personages · Gangs · Respect · Radiozenders · Bonussen · Opslaan · Multiplayer (Game Hunter) Icon GTA2 orange small.png
Collectables Badges · Kill Frenzies · Wang Cars
Modding Tutorial · Editor (Epic) · Script Compiler (MIS Pad) · STY Tool · STYed · GXT Editor · Levels installeren
Media Screenshots · Artwork · GTA2: The Movie · Ray Larabie's voertuigen
Overige Cheats · Easter eggs · Systeemeisen · Besturing · Manager · Plattegronden · Vindplaatsen · Bugs · Outtakes · Credits

Externe links

Deze pagina is online te bekijken via "http://nl.wikigta.org/wiki/GTA2_Editor"